|Published (Last):||2 February 2005|
|PDF File Size:||2.82 Mb|
|ePub File Size:||19.66 Mb|
|Price:||Free* [*Free Regsitration Required]|
The method is long, but requires very little logic. It’s pretty much step-by-step instructions. I know I could split it into several smaller methods, but considering they only ever run in sequence, I don’t see the point of that.
Is there any way I could actually make it better or shorter? When using two directly nested usingyou can write it as the following to reduce the level of indentation:.
The switch can be replaced by a dictionary to remove the boilerplate break s:. Although this code is always executed in existimg it is better to extract separate stuff to methods. This will help if you need to find a bug or if you are trying to refactor it.
Together, it makes the code difficult to read when glancing over. When using two directly nested usingyou can write it as the following to reduce the level of indentation: Writer, new Rectangle script.
Xiaoy 2, 9 My reason for breaking the lines is to keep the lines of code at 80 characters or less. It may look shorter in my post, but that is because the namespace nesting adds an additional indentation level, which I remove to post the code here. Additionally, I was avoiding using namespace to prevent complications. Several of the namespaces I am using share class names, and so I already had to fully specify a few. Is this also not true for C: MichaelBrandonMorris It is also true for Chowever, you can always alias namespace or class separately to avoid complication like ambiguous name: GetOverContent pageNumber ; is never used so you should get rid of it.
Sign up or log in Sign up using Google. Sign up using Facebook. Sign up using Email and Password.